Log In  

I don't know whether this qualifies as a "bug" per se, or just "don't do silly things", but here goes.

If you open up a cart with Code Tabs in an editor you can see they are just separated by a character sequence: "-->8".

Weird stuff happens if you manually insert these. If you insert them in the P8 editor, they'll just sit there until you next load the cart, at which point they will become new tabs.

Also the P8 editor enforces a maximum 8 tabs (labelled 0-7). If you have more than this, it will silently drop the offending extra tabs, even if they have content.

My suggestion would be to do something different - perhaps ignore extra tab separators and concatenate all the extra tabs into one? Or at least flag a warning on load.

The way I can see this being a real problem is with copy and pasting via external editor. It would be really nasty to accidentally drop part of your code this way.

P#53987 2018-07-07 14:31 ( Edited 2018-07-07 23:11)

:: Davbo

Yeah I ran into a similar problem once because typing __label__ into the code editor then reloading thinks the next part of the cart is the label. So if you type that then reload it looks like all your code under it is just gone.
Not sure what should be done about it though. Make the character sequence more complicated? Have some special ascii that you can't type into the Pico 8 editor?

P#53993 2018-07-07 19:11 ( Edited 2018-07-07 23:11)

[Please log in to post a comment]

About | Contact | Updates | Terms of Use
Follow Lexaloffle:        
Generated 2019-08-21 19:06 | 0.021s | 2097k | Q:11